Scrapy模块依赖包列表

本地虚拟环境开发完成之后,上线过程中需要一一安装依赖包,做个记录如下:

CentOS 安装python3.5.3

完成安装python3.5.3,在不删除系统自带的python2.x情况下,做几个软链:

上传程序,安装scrapy及其依赖包:

在Centos系统中安装过程中,出现一个较为淡疼的问题:系统没有安装sqlite3,故此一直提示:
解决上面问题,下载sqlite3

编译安装:

重新编译Python,找到Python3.5.3的安装文件路径,编辑setup.py脚本,找到 “sqlite3”

在最后一行加入sqlite3编译安装路径,如下:

重新编译Python3.5.3:

Enjoy it.

发表评论